Jump to content

(SOLVED) Hold S while pulling face - snapping incorrectly

Recommended Posts

(SOLVED (Workaround found): see second post from user "karl", below).

I'm following along with Gabriel on his Youtube video 'Prototyping a "Medieval House" in Unity with ProBuilder3D' (I pasted the link below and it put the video there).  My issue starts at 4:20 in the video; he says if you don't hold S while pulling a face, then it will snap to an infinite point.

My problem is that it still snaps to an infinite point even when I hold S and pull.  I've tried holding S before clicking the arrow to pull, clicking first then holding S and pulling, and other things but I can't seem to get it to work.  Can't progress in the video because of this.

About me:

PC: Windows 10, AMD ryzen 1700, 16gb ram, AMD RX 550 4gb

Unity: 2017.2.0f3 (started out using Unity betas with their built-in Probuilder, but they were so buggy for me, that I returned to the 2017 versions)

Probuilder: 2.9.8f3


Project setup (this error happened pretty early in this project so thought this info might help since I'm just starting):

- This "Medieval House" scene is in the same project as my recently completed House with Interior and Exterior from Gabriel's other YT video.

- Gabriel didn't say to do so, but I noticed at the start of his vid that he had several parts of the Standard Assets imported, so I imported all the folders he had. I then had a compiler error about a namespace called "WaterBase" in a .cs file in the Standard Assets; resolved it by doing a reimport of the Standard Assets, and pulling in the Water and Water (Basic) folders in the Environment folder.




Share this post

Link to post
Share on other sites

Minor update:

I'm also using Progrids 2.5.0f0, which is related to the "snapping" I mentioned in my OP.

When I turn off Snapping in the ProGrids toolbar, face pulling works fine.  Still need the snapping to keep the same measurements used in the video.

Please help, and thanks.

Share this post

Link to post
Share on other sites

@karl: Update: I just started a new project in the Unity 2018.1 beta that I have installed, and imported Probuilder 3.0.1 from the Package Manager. Still can't pull face correctly.

Saw in Package Manager that there was an update available from 3.0.1 to 3.0.3, did the update, problem still persists.

Is there anything I can do to solve this issue now?

Share this post

Link to post
Share on other sites

@karl: THANK YOU! I just needed a way past this error, so I could follow along with the video.

I know the procore tools are still new to being part of Unity, so bugs are to be expected; I'm very happy and appreciative that the are being offered for free.

Thanks again; I edited the OP to indicate solved (workaround found).  Just a random thought, unless it exists and I'm not seeing it, it'd be nice if this forum had a way to mark this topic as solved, and link to the post with the solution.

Have a good one.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now