Jump to content
Skyvu_Bevins

ProGroups 'Groups' errors

Recommended Posts

Hi, So I just bought the Pro Core Bundle today. Mostly for probuilder, progrids, and progroups, but couldn't pass on the rest of them. Anyways I got ProBuilder and Progrids installed and running fine, however when I import ProGroups it throws these errors:

 

Assets/ProCore/ProGroups/Scripts/Editor/ProGroups_Window.js(142,44): BCE0004: Ambiguous reference 'Group': Group, Group.

Assets/ProCore/ProGroups/Scripts/Editor/ProGroups_Window.js(249,41): BCE0004: Ambiguous reference 'Group': Group, Group.
Assets/ProCore/ProGroups/Scripts/Editor/ProGroups_Window.js(294,48): BCE0004: Ambiguous reference 'Group': Group, Group.
 
It will not work, and if I restart the editor it removes both ProBuilder and ProGrids, unless you delete the ProGroups Folder. 
 
Any help is solving this would be great, currently on Unity3D version 4.3.4f1
 
Thanks
 

Share this post


Link to post
Share on other sites
Hi there! Sorry to make you wait on this.

 

Since you mentioned in your email that this problem only occurs in a specific project, th best option I can think of, is to make a copy of the project, and slowly remove items from it, till the error goes away. Start with tools/plugins- there might be a conflict somewhere. Once you know exactly what causes the issue, we can take action right away. Unfortunately, we can't troubleshoot it otherwise, sorry :(

 

If your project is extremely large...perhaps try importing items, one by one? That might be simpler, if it is too much trouble to copy the entire project.

Share this post


Link to post
Share on other sites

Hi Gabriel, Appreciate the response. It is currently a rather large project, but we have minimal third party tools so Im going to eliminate them first and then work through our own tools. Heres hoping its an easy fix, but can atleast still get a few things functioning in the other tools. 

 

Ill give it a shot and see what I can find, but even with things being weird with our project the tools are still incredibly useful. so thank you. I will make sure they are in the next project from the start so this hopefully will not be a problem. Appreciate your time.

 

Chris

Share this post


Link to post
Share on other sites

Thanks Skyvu! Definitely let us know when you find the offending item, perhaps we can work something on our end to ensure others don't have the same issue, or contact the developer directly, if it is another tool/etc.

 

gw

Share this post


Link to post
Share on other sites

Just wanted to update you, I was able to get proGroups working. Turns out an editor we use for setting up events/spawns/ect was using a group call. So that is taken care of now and everything is working on that end. Now I just need to figure out the issue with missing reference excepetion and the game objects with proGrid. 

 

Thanks alot for your help.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×