Jump to content
Sign in to follow this  
calebhc

Lightmap Issue

Recommended Posts

Hello!

I've been having this weird issue with baking dual lightmaps where I'm getting light leaks. I've attached a screen shot of the problem I'm having. For the last few hours I've been experimenting and searching the forums but I haven't found a solution yet. I'm using Pro Builder 2.0 and Unity 4.1. Am I just doing the baking wrong with Pro Builder? It seems like the no-draw surfaces are not blocking the light.

BHSLJWhCQAAAWBJ.png:large

Thanks for your help!

Share this post


Link to post
Share on other sites

Thanks for posting this so quickly!

Could you test the following:

1) Are you using ProGrids to ensure the edges are perfectly aligned?

2) Can you try the newer version of ProBuilder that I emailed you?

This was an old issue that should be fixed, but we'll re-tackle it if needed!

Share this post


Link to post
Share on other sites

Hello!

No problem! Thanks for sending me the newest version. :)

I tried out version 2.1.1 but I'm still having the light leaking issue. I tried also creating new walls but the no draw surfaces are still not blocking the directional light. I am using ProGrids so everything is nice and lined up. I even tried pinching the corners in like the Pro Builder doc showed but still the same result.

Is there a way I can just select all of the No Draw surfaces and then tell the Light Mapper to give them a 0 scale so they are ignored? Or maybe I'm still doing something wrong?

Thanks for the help!

- Caleb

Share this post


Link to post
Share on other sites

Hmm. I think you need to refresh the UV2s for all your objects. (regarding the 0 lightmap scale, ProBuilder already does that automatically- best not to mess with it!)

So, to refresh those UVs, click the "Lightmap Setup" button in the ProBuilder panel (the lightbulb). Then open the "Advanced" area to show a few special buttons.

At this point, backup your project! ;)

Now, make sure the settings are, in order "8, 15, 88, 20". Then, click "Refresh All", "Apply Settings to All", "Make Current Settings Default".

Run your lightmaps, and see if that does the trick!

Share this post


Link to post
Share on other sites
I'm running into the same issue.

The latest version of ProBuilder, using Progrids, geometry overlaps by .25 but still have light in the seams.

Here is a screenshot:

http://www.edje.net/Capture.PNG

Can you try the same steps I mentioned above? I think you may need to refresh the UV2 params.

Also, a .25 overlap will actually cause seams, in many cases. Best to have exact edge-to-edge placement.

Share this post


Link to post
Share on other sites
Hmm. I think you need to refresh the UV2s for all your objects. (regarding the 0 lightmap scale, ProBuilder already does that automatically- best not to mess with it!)

So, to refresh those UVs, click the "Lightmap Setup" button in the ProBuilder panel (the lightbulb). Then open the "Advanced" area to show a few special buttons.

At this point, backup your project! ;)

Now, make sure the settings are, in order "8, 15, 88, 20". Then, click "Refresh All", "Apply Settings to All", "Make Current Settings Default".

Run your lightmaps, and see if that does the trick!

Well, I tried this out and still no luck. :( Did I maybe upgrade wrong? Single lightmap baking is working fine though. Just can't figure out why dual is showing leaks. Is there any other trick I can try? :)

Thanks

Share this post


Link to post
Share on other sites

I had similar issues, I have not tried since updating to the latest version.

But I did have issues when rendering path was Deferred Lighting. Perhaps try Edit->Project Settings->Player under "Other Settings" set rendering path to Forward

Share this post


Link to post
Share on other sites
I had similar issues, I have not tried since updating to the latest version.

But I did have issues when rendering path was Deferred Lighting. Perhaps try Edit->Project Settings->Player under "Other Settings" set rendering path to Forward

Hi Linus!

Yep, switching to forward rendering totally fixed it! :) I wish though that the deferred lighting would work. Maybe there's still a way? :D

In the meantime, forward rendering should be okay. Thanks for the tip!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×