Jump to content
KirilZ

Pivot and Merged Objects gone?

Recommended Posts

Hello,

 

I have 4 meshes that I merge, to create a nice roundabout.

 

They become one, then I pivot it in the center of the object.

 

Export, or remove probuilder scripts, the pivot goes into the abyss flying, nowhere to be seen.

Also tried it without merging the objects, same issue.

 

What is going on?

 

 

2, why is it when I merge the objects and export, I get an object with 4 children / meshes to it, rather than 1 object/mesh...?

 

 

Thank you.

Share this post


Link to post
Share on other sites

Hmm... they do merge though, only when I export it they show up as separate objects, no errors at all, nor warnings.

 

What about The Pivot...???? I really want the pivot to be proper, if I can set the pivot to center (Which it does while in probuilderized, but once exported its gone.)

THen I can proceed with my project for this shape, why is it disappearing, how to solve this? Shall I upload you the mesh and you can look into it yourself?

Share this post


Link to post
Share on other sites

Okay,

well really its 2 issues. The pivot is my main concern.

 

Watch this, It is 1 merged object. I will set the Pivot when everything is selected so it is centered. Then I will select just the object, as you can see pivot is mia?

 

Next,  I will export as you suggested, and as you can see when I place the item in the scene it is multiple objects and pivot still mia.

 

Help? I've included the .obj in the zip as well as the video: https://www.dropbox.com/s/gw4gwes7ng3eeow/probuilding.rar?dl=0

IT's 1 minute and 41 seconds of me fiddling around, speed up the video if it shows more than that time sometimes when I upload it slows down the video and making it longer...

 

Share this post


Link to post
Share on other sites

In the top left of the Unity editor it looks like your pivot mode is set to "Center." Try changing it to "Pivot" if you want the handle to appear where you set the pivot point of the ProBuilder mesh.

The reason "Center" is way out in the distance is probably because the mesh you've selected is merged with another unrelated mesh. Use the ProBuilder "Detach" action to split off objects that have been merged.

Share this post


Link to post
Share on other sites

Ah, indeed you are correct regarding the Pivot being set to Center, this fixed that.

 

I am not sure where to Find "Detach" action, I found Detach faces. And in the Actions option there are only 4, which show no "Detach" option at all.

 

Did you watch the video? Can you see that it merges into one object, then when I export it as .obj and import into Unity it is a parent with 4 meshes...

 

I would really like to finalize this object and get on with it...

 

I just tried again, I merged all the meshes into 1 probuilderized mesh/object in scene. Set the pivot to center when all faces are selected, I went and selected Detach faces, the message came up " No faces selected " I selected them all again and Set Pivot.

 

Exported as object, Pivot not exactly at the same place but I can live with it, however just as in the video now I have 4 child meshes with 1 parent.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×