Jump to content
Sign in to follow this  
quid3st

Vertex connect failure

Recommended Posts

Hey,

I'm trying to connect some vertices, which I created along the map, in order to add detail to geometry. However, the "Connect vertices" feature works only 50% of the time. And when it fails, no error is shown. Instead, a regular "Connected 2 vertices" is shown, and no edge is created between the vertices.

Edit: Added video down below

edgeConnectBug.png.0615170d679e7f07604b4023cacc9892.png

These vertices were created by subdiving the edges, which they lie on. I moved the left vertex down, and right vertex up, in order to make this clear in the following image:

vertexConnectBug2.PNG.a2e832e655cd6415316ae716727d1ed6.PNG

This kind of edge subdivision and vertex connecting works half the time, and I never get an error message.

EDIT: I also created a video to replicate the issue. It seems the problem is when I extrude a face, instead of bridging them. I realize this might not be a bug. But it would be nice if the extruded plane's vertices would react well to vertices that are on a plane next to it.

2018-02-16 09-10-56.mp4

EDIT 2: I tried bridging some of the edges in my geometry, in order to correctly connect vertices, but I am unable to. Is this a bug or am I doing something wrong? Can be seen in the following video:

2018-02-16 09-22-15.mp4

Unity 2017.3.0f3

Probuilder2.9.7f5

Thank you!

 

 

Share this post


Link to post
Share on other sites

It looks like bridge edges is complaining that you're creating a face between two manifold edges. In the preferences panel (Preferences > ProBuilder) under "Geometry Settings" there's a toggle for "Bridge Perimeter Edges Only." Disable that checkbox and you should be able to create a face between those edges.

Share this post


Link to post
Share on other sites
On 2/16/2018 at 5:32 PM, karl said:

It looks like bridge edges is complaining that you're creating a face between two manifold edges. In the preferences panel (Preferences > ProBuilder) under "Geometry Settings" there's a toggle for "Bridge Perimeter Edges Only." Disable that checkbox and you should be able to create a face between those edges.

Thanks, this worked!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×