Jump to content
KyleYoungblom

Snap Only On Specific Axis

Recommended Posts

I'd love to see the option to only apply progrids snapping to the axis used to translate the selected component. In the example below, I grab the top verts of a cylinder and translate them upwards using the Y axis of the transform gizmo. The verts snap properly to the .5 on Y but also snap on the X and Z axis, which is not desired. The only workaround I know of is to create a second object at the Y height I want, disable snapping in proGrids, and then hold V to vertex snap to my new object. This works but isn't really an ideal workflow. Thanks

 

image.png.150f0caed0ba63862e39a266b78ca441.pngimage.png.d141af07993111ff55617c334208f7d5.png

Share this post


Link to post
Share on other sites

ProGrids actually has two modes:

- Snap On All Axis
or
- Snap on Selected Axis Only

By default, this is set to "Snap On All Axis", but you can hold "S" on the keyboard to activate the opposite (while the key is held down).

Alternatively, you can change the default to "Snap On Selected Axis Only" via the ProGrids Preferences, under "Edit > Preferences > ProGrids"

Hope that helps, sorry it isn't very clear!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×