Jump to content
Sign in to follow this  
OreoSplitter

Select by material and select by colors should be removed from edge and vert tabs

Recommended Posts

This button works as expected in faces tab but in vert and edge it's useless. I have found while in edge or vertices, if a side has more then one face, getting Select by material to activate (not be greyed out) is impossible  to do. Which questions why is it even located in those tabs at all. I cant have a side with 4 faces, in edge mode select 4 edges around one of those faces to get that button to show. So why is it even in those sections? The manual and video tutorial only mention using it in faces.

 

Now that I am looking at it select by color looks like the same issue. I think someone should go through all the buttons and make sure they apply to the section if a button is missing (select drag to edge tab) or one needs to be removed. I'm a month into using probuilder so maybe I am just missing the idea of how these buttons are organized from your point of view.

Share this post


Link to post
Share on other sites

There's a preference in ProBuilder that allows you to select faces in edge or vertex mode by clicking in the center of the face. That's why some face actions are enabled in vertex and edge mode. However it may be a bug that these options are shown when that preference is not enabled, I'll double-check.

Share this post


Link to post
Share on other sites

What is the setting and what is it called to allow selecting faces while in other modes because that would make sense why those buttons would be in other tabs. By default in edge and vert mode  I can select faces if it's the only face there including adjacent faces. In other words a face with only 4 verts. A side with 4 faces though, I can't any select faces in those tabs which made those buttons feel useless.

After some messing around I turned on Precise Element Selection and everything works properly. It now makes sense for those buttons being there as I can select individual faces from edges and verts. I am happy now I can easily select surrounding edges and verts. I think it should be on by default unless I accidentally turned it off.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×