Jump to content
KyleBriggs

ProBuilder [2.9.3f0] - Can't Preview Unlit

Recommended Posts

A few days ago I started a new scene, added in a few of my standard models (created through Blender & imported in), then got to work building my connecting corridors using ProBuilder, when I got to a large open room, which I modelled using ProBuilder, I noticed that when I had a shader on it, I was unable to preview it unlit.

If I duplicate the object using the standard Unity way (Crtl+D), the new copy has the correct lighting (none) when the Light icon is off, see HERE for info on the icon (the one that looks like a sun).

Unfortunately, I don't really want to have to keep duplicating my objects every time I want to see them (large room, few lights = DARK) so I bit the bullet, deleted ProBuilder (and the ProCore bundle entirely) and started again with fresh installs of all of them, the same problem.

Does anyone else have this problem or know a solution?

Share this post


Link to post
Share on other sites
45 minutes ago, karl said:

Could it be that your objects are lightmapped? If that's the case, you could just clear your lightmap and turn off continuous baking.

Hi Karl, thanks for replying.

 

I already have continuous baking turned off (got very annoying), and I did indeed have lightmapping baked, but upon deleting them, the PB objects didn't seem to clear, unlike all the others which did, the PB objects still appeared to have their lightmapping details on them, even after clearing.

Share this post


Link to post
Share on other sites

That's strange. Okay, try this:

- In the ProBuilder toolbar, open the options for "Generate UV2" (alt+click if you're using icons, or + button if text) and turn off "Enable Auto UV2."

- In Tools > ProBuilder > Repair run the "Refresh Scene" action.

- Open Light Settings, clear lightmaps.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×