Jump to content
Sign in to follow this  
spooky

Losing Lightmap Static

Recommended Posts

I'm having an issue where the default static flags for new ProBuilder Objects doesn't include Lightmap Static, which it did before. I can't find a default setting to change this, but it's not really an issue, manually checking LMS isn't that much trouble, but several types of PB operations will cause a PBO to automatically uncheck its LMS flag.

As tagged, I'm not sure if this is a bug, or if I don't understand something about the ProBuilder workflow; however this has only been an issue for me since I updated to the most recent Asset Store version of PB.

Share this post


Link to post
Share on other sites

It's because you have "Auto Generate UV2" disabled. Once you generate the UV2 channel for the objects they will automatically have the Lightmap UV flag turned on again.

The reason for doing this is that objects marked as "Lightmap Static" with either bad or missing UV2s will introduce artifacts in the lightmap texture.

Share this post


Link to post
Share on other sites
21 hours ago, karl said:

It's because you have "Auto Generate UV2" disabled. Once you generate the UV2 channel for the objects they will automatically have the Lightmap UV flag turned on again.

The reason for doing this is that objects marked as "Lightmap Static" with either bad or missing UV2s will introduce artifacts in the lightmap texture.

Ah ok. I had Auto Generate UV2 disabled because it wasn't reliably regenerating the the UV2s in an earlier version and I guess the setting carried over because I didn't do a clean install.

By the way, is there a way to set the default UV2 parameters? I'm using low res (Quake-like) lightmaps and the Pack Margin must be set to at least 32 or there will be significant light bleeding errors. Setting the parameters every time I use the New Shape button gets tedious.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×