Jump to content
Sign in to follow this  
mysticcoder

ProBuilder Render UV workspace texture broken

Recommended Posts

Version 2.6.5f0

 

Trying to render out UV templates to png images, it's completely broken. My object is a fully welded, manually UV wrapped "room". Attached images should show the problem reasonably well enough.

 

Things noticed:

- Depending on image size, the results change.

- When face materials is on in the UV editor, they are not rendered in the correct place / scale .. etc.

- The edges are not rendered in the correct place.

 

Perhaps it's just the object I'm testing, but it is properly welded and unwrapped (see images).

post-1686-0-78365500-1481176985_thumb.jpg

post-1686-0-18444700-1481176996_thumb.jpg

post-1686-0-00889100-1481177090_thumb.jpg

post-1686-0-51041900-1481177345_thumb.jpg

Share this post


Link to post
Share on other sites

Hm, I just checked Unity 5.3.5 on my Macbook Pro running in retina, seemed to work as expected.  

 

Unity 5.5.0f3 on the other hand exhibits the problem behavior.  That makes sense, 5.4 introduced scaled screen support - should be a quick fix.  

 

As a workaround you could always temporarily turn retina display off, render, then re-enable.

Share this post


Link to post
Share on other sites

Thanks for locating this. I'll be using it extensively shortly (hope next version is out soon!)

 

For the time being I've just done a screen capture and cropped and scaled the UV editor contents, but that would get old fast!

 

- Also whilst you're at it, I wonder if you'd be able to add an option to render to non-square textures. In this example, I'm creating a 4096x2048 texture as the layout of the UV space is intended for a wider than high texture; i.e. not all textures are square.

 

Thanks again.

Share this post


Link to post
Share on other sites

I have been having this issue since I began working with pro builder advanced about a year ago. It would be nice to make use of it. Mostly what I get anytime I try to save a Rendered UV export to PNG is a garbled mess of lines. Also using a Mac with Retina display. I have tried to render it under different resolutions and it has the same issue. Also, the render was ineffective when I scaled down the resolution on my MacBook Pro Retina. 

test.png

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×