Jump to content
Sign in to follow this  
ProBuilder1

Errors and lost data written to Plane from ProBuilder

Recommended Posts

Hello.

 

I just got PolyBrush beta 0.9.4b0 and imported. No issues, seemed okay.

 

Tried to you it with a plane created from ProBuilder and got the following error messages, corrupted, then lost data.  If ctrl+z, the written brush data is gone and I'm back to a flat plane, back to step one, create plan data.

 

Attaching pictures to show also Scene view goes blank. Ctrl+Z fixes that, again, back to default plane version prior to PolyBrush edits to the plane.

 

Replication was pretty simple. 

 

1. I created a plane from ProBuilder (properties should not matter, default is fine)

2. edit with PolyBrush.

... at some point of using PolyBrush button one (raise terrain style button, or mesh in this case), is where critical error happens, stopping me from further edits.

 

 

AmbiguousMatchException: Ambiguous matching in method resolution
System.Reflection.Binder.FindMostDerivedMatch (System.Reflection.MethodBase[] match) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/Binder.cs:106)
System.MonoType.GetMethodImpl (System.String name, BindingFlags bindingAttr, System.Reflection.Binder binder, CallingConventions callConvention, System.Type[] types, System.Reflection.ParameterModifier[] modifiers) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System/MonoType.cs:245)
System.Type.GetMethod (System.String name, BindingFlags bindingAttr) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System/Type.cs:787)
Polybrush.z_ReflectionUtil.Invoke (System.Object target, System.Type type, System.String method, System.Type[] methodParams, BindingFlags flags, System.Object[] args) (at Assets/ProCore/Polybrush/Code/Editor/Classes/z_ReflectionUtil.cs:138)
Polybrush.z_ReflectionUtil.Invoke (System.Object target, System.String method, BindingFlags flags, System.Object[] args) (at Assets/ProCore/Polybrush/Code/Editor/Classes/z_ReflectionUtil.cs:105)
Polybrush.z_EditableObject.Apply (Boolean rebuildMesh, Boolean optimize) (at Assets/ProCore/Polybrush/Code/Editor/Classes/z_EditableObject.cs:166)
Polybrush.z_Editor.FinalizeAndResetHovering () (at Assets/ProCore/Polybrush/Code/Editor/Interface/z_Editor.cs:816)
Polybrush.z_Editor.OnBrushExit (Polybrush.z_EditableObject editableObject) (at Assets/ProCore/Polybrush/Code/Editor/Interface/z_Editor.cs:781)
Polybrush.z_Editor.SetTool (z_BrushTool brushTool) (at Assets/ProCore/Polybrush/Code/Editor/Interface/z_Editor.cs:366)
Polybrush.z_Editor.OnSceneGUI (UnityEditor.SceneView sceneView) (at Assets/ProCore/Polybrush/Code/Editor/Interface/z_Editor.cs:441)
UnityEditor.SceneView.CallOnSceneGUI () (at C:/buildslave/unity/build/Editor/Mono/SceneView/SceneView.cs:2068)
UnityEditor.SceneView.HandleSelectionAndOnSceneGUI () (at C:/buildslave/unity/build/Editor/Mono/SceneView/SceneView.cs:1405)
UnityEditor.SceneView.OnGUI () (at C:/buildslave/unity/build/Editor/Mono/SceneView/SceneView.cs:1242)
System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222)

post-1472-0-22779300-1463020702_thumb.png

post-1472-0-86996100-1463020719_thumb.png

Share this post


Link to post
Share on other sites

Ok, rad.  The latest version is 0.9.6, and that particular ProBuilder bug was fixed in 0.9.5.  The Asset Store window is odd sometimes in that it refuses to download the latest package - try hitting "Update" even if it's grayed out, then Import again.

 

Alternatively if you have a Github account you can PM me your invoice # and receive access to the Polybrush repository with all the available builds.

Share this post


Link to post
Share on other sites

Thanks!

 

I purchased on the Website this time around.

 

User Toolbox

 

This has the latest too?

 

I have my PayPal receipt, with their invoice number (very long string at that). But I don't think I ever got a PolyBrush Beta recite yet.  As I'm not finding it.  I usually get the Unity Invoice #. 

 

I PM'd you another invoice # and message with it. See if that helps track down my PB purchase yesterday.

 

Yes, I have a Github account too.

 

 

Thanks

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×