Jump to content
Sign in to follow this  
Able101

ProBuilder Basic 2.4.11f0 + Unity 5.3.4 Personal lag when extruding faces

Recommended Posts

i tried ProBuilder (Prototype) a few months back and it worked like a charm then. Today I downloaded the latest version 2.4.11f0 but notice some lag when extruding. the scene view constantly freezes for a second or two while extruding faces. also the faces texture changes to horizontal lines when being extruded which never happened previously. has anyone else experienced these issues?

 

system specs: macbook air yosemite 2013 with Unity 5.3.4 personal + probuilder basic 2.4.11f0.  

 

was thinking of upgrading to pro during the community sale but not sure if its my system that's causing the lag or is it pb? everything else works well without any lag. i use blender and there's no such problem. appreciate the help, thanks!

Share this post


Link to post
Share on other sites

Try disabling automatic UV2 generation, it's a setting in the Preferences/ProBuilder panel.  Most of the time this is the issue.  Just remember to generate UV2s before baking lightmaps!

 

Another potential cause is working with high vertex count prefabs.  To see if that's the issue, try using the GameObject/Disconnect Prefab Instance menu item then editing.

Share this post


Link to post
Share on other sites

thanks for your quick reply. I tried disabling auto UV2 generation from Preferences/ProBuilder panel. then created a basic cube by hitting cmd + k. tried extruding and problem persists. double checked if it was disabled. then restarted unity. tried again but lag still visible. also the lag is quite noticeable once i extrude around 10 cubes. During the lag i also notice some progress bar notification right below the "add component" button in the Inspector window. It's hard to get a snapshot of the progress bar as it lasts for about a second or so. I haven't created any prefabs yet. Its just the basic cube pbo which i instantiate and extrude and experience the lag. 

Share this post


Link to post
Share on other sites

that did it! unchecking "Auto" under the Scene Tab of the Lighting window removed the lag problem. You are awesome, thanks :  ) I further tested by unchecking "Disable Auto UV2 Generation" from the ProBuilder Basic section under Preferences. And all seems to be working well. Looking forward to upgrading to the Probuilder Advanced during the community sale. thanks again for your help, appreciate it

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×