Jump to content
Sign in to follow this  
supadupa64

QuickBrush Broken on start

Recommended Posts

I open quick brush for the first time after downloading it and all the buttons are grayed out and can't be clicked.  It's like the window is inactive.  I can't create a new folder either.  I click the blue folder and it tuns yellow for a second and nothing happens.  I get this error in console.

 
DirectoryNotFoundException: Directory 'Assets/ProCore/QuickBrush/Templates' not found.
System.IO.Directory.GetFileSystemEntries (System.String path, System.String searchPattern, FileAttributes mask, FileAttributes attrs) (at /Users/builduser/buildslave/mono-runtime-and-classlibs/build/mcs/class/corlib/System.IO/Directory.cs:514)
System.IO.Directory.GetFiles (System.String path, System.String searchPattern) (at /Users/builduser/buildslave/mono-runtime-and-classlibs/build/mcs/class/corlib/System.IO/Directory.cs:308)
qb_Utility.GetTemplateFileDirectories (System.String directory) (at Assets/ProCore/QuickBrush/Editor/Classes/qb_Utility.cs:390)
qb_Utility.GetTemplateFileSignatures (System.String directory) (at Assets/ProCore/QuickBrush/Editor/Classes/qb_Utility.cs:359)
qb_Painter.UpdateTemplateSignatures () (at Assets/ProCore/QuickBrush/Editor/Windows/qb_Painter.cs:3138)
qb_Painter.RenderTemplateMenu (UnityEngine.Event curEvent, Int32 tabIndex) (at Assets/ProCore/QuickBrush/Editor/Windows/qb_Painter.cs:1462)
qb_Painter.OnGUI () (at Assets/ProCore/QuickBrush/Editor/Windows/qb_Painter.cs:1050)
System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono-runtime-and-classlibs/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222)
 
 
What is this?

Share this post


Link to post
Share on other sites

For whatever reason it appears the Templates folder was not created on import.  You can just create a new folder named "Templates" in the QuickBrush folder to get things working.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×