Jump to content
Sign in to follow this  
Matt1988

[Release] ProBuilder Offset Tool!

Recommended Posts

This is great, thanks Matt1988! I'll have to find a way to feature these extensions- maybe if you even feel like making a short video/written tutorial covering the basics of how you put this together? We might have to set up a special documentation for it as well, I think Karl is actually on that already. I love the idea of people adding to and extending ProBuilder.

Share this post


Link to post
Share on other sites

I was actually in the middle of creating a written tutorial when I decided to take a break to check the forums!

I'm trying to include as many use cases as I can so it might take a couple of days but I will get that up as soon as I can!

Also a wiki style section of the site would be great if you want help with guides and some documentation.

Found a new bug (fixed, will be included in the next update):

If you already have pb_Objects selected in the scene when you open the offset tool, it won't recognize that they are selected.

to get around this just re select them after you open the window.

Share this post


Link to post
Share on other sites

Awesome, looking forward to the tutorial. Yep, we'll have to figure out how to make this super accessible. After all, ProBuilder only exists because of the documentation/help/examples that led me to extending the Unity editor :)

Share this post


Link to post
Share on other sites

If you already have pb_Objects selected in the scene when you open the offset tool, it won't recognize that they are selected.

Just realized that the ProBuilder window also exhibits this behavior. Fixed it; thanks for making me second guess my work :lol:

Share this post


Link to post
Share on other sites

Yeah, that's ProBuilder's fault. Up to r730-something there was a bug that caused Unity to crash when importing packages with the PB window open. It does successfully import the package, it just crashes after.

Share this post


Link to post
Share on other sites
It runs now but says 'Pick a PB object' (I did).

Hey terrymorgan! I've successfully recreated this issue and it seems to be an old bug that I thought I had already fixed in a previous version.

The problem is that the script doesn't get all of the currently selected PBO's when it is started only when the selection is changed so if you start the script with a PBO already selected it won't recognize that a PBO is selected until the selection is changed in the Unity Editor.

Thanks for bringing this up and a fix is on the way!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×