Jump to content
Protozoaire

Selection of probuilder objets are 2s delayed

Recommended Posts

- Windows 10 x64

- Unity 5.2.2f1 Personal

- ProBuilder 2.4.8f1

 

When I select a ProBuilder object, I must wait 2 seconds before it is actually selected. If I need to select 10 objects, it's 20 seconds to wait.

But after the selection is done, I can select it again without waiting anymore.

If I load another scene and come back to the first scene, I need to wait again with each selection.

 

573350SlowSelection.gif

 

In white, Unity 3d objects.

In grey, ProBuilder objects.

Share this post


Link to post
Share on other sites

It's an empty projet created with just ProBuilder plugin and the scene you see on the image.

No errors in the console.

This behavior occur with my main project too and all scenes.

 

If I click on the play button, then come back to my scene and select PB objects it works with no delay.

But then I click on stop and the delay is 2s again on all PB objects.

Share this post


Link to post
Share on other sites

That lag was not present a few months ago but I don't know what happened.

 

I made new tests with ProBuilder Basic instead of Advanced : It's the same, that's strange ...

 

230296test2pbbasic.gif

 

Your other plugins like ProGrid and QuickEdit works with no lag :

 

804156testquickedit.gif

 

But with PB Advanced or Basic, every change I make, every selection, every material I apply, there is a lag (1 or 2 seconds) :

 

534320test3.gif

 

It makes me crazy ^^ Have an idea of what can cause that issue ?

Share this post


Link to post
Share on other sites

The only thing I can think of is that maybe the Scene isn't being redrawn immediately.  If you click a face then move the scene camera does that get the selection to show, or is the scene frozen until the highlight shows?

Share this post


Link to post
Share on other sites

Okay, glad it's working!  However that still sounds like a bug to me - generating UV2s shouldn't take anywhere near that amount of time on a small object, and it definitely shouldn't be re-building every time you select an object.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×