Jump to content
Sign in to follow this  
imGua

hiding triggers dissables colliders

Recommended Posts

@karl, I have latest version and it does re enable them there. But I'm not sure why are you disabling collides at all and not just disabling mesh renderers. Cause current approach still creates some problems. I still can't view those buttons as buttons used just to hide colliders and triggers, cause if I forget to enable them when I need to bake navmesh, it will create problems.

Share this post


Link to post
Share on other sites

If I'm remembering correctly, the reason colliders are disabled when toggling visibility is because Unity's mouse picking code uses colliders, and you don't want invisible items intercepting mouse clicks.  I'm not sure if this is still the case (the last time I touched that code was probably Unity 3.5 era).  I'll look at that this week and see if that can be changed.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×