Jump to content
Johnny

Vertex and Edge Handle culling problem

Recommended Posts

Hello there,

I'm having a weird problem with the latest version of ProBuilder (bought it some days ago, i've tried emailing probuilder but no answer as of now).

The vertex handles and the edge handles don't seem to be appearing through geometry like I see in most tutorials and documentation I find about the program.
I used Prototype to test the software for some days before and I was fascinated at how quickly I was able to move vertexes around by box selecting them through geometry (everything was working fine there).

In the newest version I bought, however, the vertex handles show up as white (not blue) unselected and I can't see or select them through other geometry.
I've attached a picture to show what I mean. In the left, you see the proper behavior I'd expect from your tool, in the right you can see my case.

Some extra information:

  • I also added ProTools' QuickEdit in the plugins I imported.
  • I successfully upgraded to ProBuilder 2 from Prototype by following your upgrade guide and downloading the Upgrade Kit. Nothing out of the ordinary happened and it all seems to be working fine apart from my issue.
  • I'm running Unity 5.0.2 atm and I have a 64 bit Windows 7 system.

It's starting to becoming a nuisance since the more complex my scene gets the more I have to twist the camera around to get to the vertex handle I want.
I upgraded to make the most use of the tool and speed up development but it seems I actually got a setback for now. I hope you can help me.

I'd love to hear back from you soon, thank you.

 

post-856-0-55894900-1436253663_thumb.png

Share this post


Link to post
Share on other sites

Hey Johnny, apologies for the tardy email reply; Gabriel (who handles email) is out of the country at the moment with limited access to internet.

 

The latest version of ProBuilder introduced the new z-tested vertex handles, which was intentional.  It wouldn't be too hard to add a preference to toggle culling for those handles though, I'll make a ticket to do so.

 

In the meantime, you can change this yourself by changing the ZTest parameter in the pb_VertexShader file.

// change this line (13) in pb_VertexShader.shader
ZTest LEqual
// to this
ZTest Always

Share this post


Link to post
Share on other sites

No problem, I've been managing just fine. It's just that I got used to the previous workflow and then got confused if this was intentional or a bug. I can see situations where it makes perfect sense to keep it as it is but, yeah, adding an option to the preferences to have it behave like the older versions is great for some situations where the scene you're editing is too complex. It was also the first place I went to check for an option that re-allowed it back so it should definitely exist there.

Thanks a lot for the short term solution too, we're running a tight schedule and getting ready for Gamescom and this will certainly speed things back up again.

Issue resolved! :)

To celebrate, here's a tease of what we're working on:
render_Unity3.png

Share this post


Link to post
Share on other sites

Postscript:

While it did start showing vertexes through geometry, it seems that actually selecting them is difficult now if you try to do it through a wall.
Some are selectable, others aren't. Is there a way to get around this?

EDIT: Changing the vertex handle size seemed to fix this issue. Weird.

Share this post


Link to post
Share on other sites

There's a known issue with high dpi screens being difficult to select vertices as well.  You can also set the selection mode to disable/enable selecting hidden vertices right underneath the pivot enum field in the editor window- make sure it's set to "Select All" and not "Select Visible."

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×