Jump to content
Sign in to follow this  
Gibmation

Pause/Lag between editing PBOs

Recommended Posts

Hi Guys,

 

Using Unity Pro 5.1.1f1

I have a lot of objects on scene. The objects have not been created with PB.

These objects are in ProGroup layers and visibility is turned off on these layers.

So only the PBOs are currently visible in editor.

 

 

I am experiencing some sort of lag while editing PBOs.

I am starting off with a simple cube and just creating walls and arches.

 

Eg.

 

  • If I drag or manually extrude a face, there is a pause between the time I drag and the time it actually moves on screen while this happens the unity is frozen.
  • If I delete or merge faces, maybe only 4 in number, although I can see faces get deleted/merged in seconds on screen, the editor pauses or lags and unity is again frozen - it can take up to 5mins for the editor to become usable again.

 

However I don't get this issue when doing other stuff like connecting or bridging edges.

 

There are no errors in console.

 

You can get a videoclip of this here:

http://linares.gi/video/Probuilder.rar

 

As you can imagine a couple minutes lag every time between actions renders ProBuilder practically unusable.

 

Thanks for your help

 

Gus

Share this post


Link to post
Share on other sites

There's a known issue with models that have a large number of vertices slowing down the editor, though I haven't seen anything like 5 minute lags yet.  Are you using booleans to create those archways?  That could be unnecessarily increasing your vertex count.

 

I have some ideas on performance improvements with large meshes that I've been wanting to try, I'll see if I can make time this week or next to look at that.

Share this post


Link to post
Share on other sites

There's a known issue with models that have a large number of vertices slowing down the editor

 

 Are you using booleans to create those archways?  That could be unnecessarily increasing your vertex count.

 

Hi Karl thanks for the reply.

 

I am not editing any of the existing models, these have many verts but I'm not touching those, I have them turned off.

 

I made the archways using PB's built in geometry arches bridged together.

 

They dont have that many verts.

 

I made a simpler single archway and was also noticing this lag, could this object type be the problem?

Have also noticed when making walls from Cube geoo, after wall gets a certain size its starts lagging.

 

Could the actual size of the faces not the amount of verts be the problem?

 

Would PB check the other models or just PBOs?

 

I have noticed the same type of delay if I do a Ctrl A and select all objects in my scene, though not as long.

 

I exported the bridge object to a new project, I can move faces fine here but I do notice a sml lag, but this is liveable, however I selected a face and clicked delete button and unity freezes.

 

When editor response came back I did a Ctr Z and its crashed unity now.

 

You can test this object if you want here...

 

http://linares.gi/video/bridge.rar

 

Try deleting the face with the arches.

 

Thanks

 

G.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×