Jump to content
Sign in to follow this  
lundon

Deleting an object deletes everything in progroups

Recommended Posts

Maybe I'm missing something here. If I select an object in my scene that is part of a group and then hit delete (or right click and select delete) all of my groups disappear. I also get a large list of errors that say:

 

MissingReferenceException: The object of type 'GameObject' has been destroyed but you are still trying to access it.
Your script should either check if it is null or you should not destroy the object.
ProGroups.ProGroups_Window.ConcatString (UnityEngine.GameObject[] array) (at Assets/ProCore/ProGroups/Scripts/Editor/ProGroups_Window.cs:520)
ProGroups.ProGroups_Window.OnGUI () (at Assets/ProCore/ProGroups/Scripts/Editor/ProGroups_Window.cs:397)
System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono-runtime-and-classlibs/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222)
 
I'm using Unity 5.01
 

Share this post


Link to post
Share on other sites

You might also check something else. I don't think I was able to add the same object to more than one group. I'm not at the right computer just now, so i can't check if that was the case.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×