Jump to content
Sign in to follow this  
sfbaystudios

Fitting UVs into place -- Not sure of the right terms to use

Recommended Posts

Hello!  Please excuse that I really don't know the right terms to discuss UVs.  It's all brand new to me.

I've made a little pillar in ProBuilder, and I'm trying to use it in Substance Designer.  I've opened the UV editor and moved the UVs so they're not on top of each other.  However, it looks like there's a bounding box of sorts, and the UVs are outside of it (and much larger than it).

Before I moved the UVs, they were kind of stacked on top of each other (is that normal?), but the longer pieces were extending beyond the frame of the "bounding box".

I have no doubt I've made quite a few mistakes in my workflow here, but is there away to kind of automatically position the UVs so they're not stacked and are all within the box?

 

Thanks!!

 

post-672-0-87291000-1427574328_thumb.png

post-672-0-49695800-1427574330_thumb.png

Share this post


Link to post
Share on other sites

It's normal for UVs to be overlaying one another while in auto-unwrapping mode, which is shown with the blue highlight.  To get them fitting into the bounding box, just select your faces, set them to "Manual" ,arrange them such that they're not overlapping, then hit 'Fit UVs'.

Share this post


Link to post
Share on other sites

Excellent -- thanks so much!

Is it possible to somehow re-do UVs on models that already have them set?  I have a bunch of models with UVs in an atlas.  I'd like to modify the shape of some of the models and re-texture them, but the UVs are in the middle and "fit UVs" doesn't expand them to fill the bounding box.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×