Jump to content

Search the Community

Showing results for tags 'prefab'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Introduce Yourself
    • Showcase and WIP
  • ProBuilder
    • General Discussion
    • Bug Reports
    • Feature Requests
    • Extensions
    • Tutorial Requests
    • ProBuilder Contests
    • ProBuilderVR
  • Polybrush
    • Feature Requests
    • General Discussion
  • ProCore Utility Tools
    • ProGrids
    • ProGroups
    • QuickBrush
    • QuickEdit
    • QuickDecals
  • GILES (Generic In-Game Level Editing System)
    • Feature Requests
    • General Discussion

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 15 results

  1. The other day I tried to use the Polybrush prefab painter for the game I'm working on for school however the prefabs didn't seem to appear. After looking at the hierarchy, though I could see they were there. To me it seems like they're placing at random coordinates on the mesh instead of where my brush is clicked. I was wondering if I'm just spacing and this is operator error, or if this is an actual bug. I have the newest version of Polybrush and unity 2018 beta
  2. Hi there, thanks for your awesome tools! We're struggling with an issue in Probuider v2.9.8f3 On a probuilderized FBX with materials in Unity 2017.3.0f3, after merging it into one mesh via probuilder and making it a Unity prefab, it's impossible to change materials anymore, they are locked, any change is reverted if pressing "Apply" on the prefab. Steps : import an FBX file with materials in it > Probuilderize it > Merge it > Make it a Prefab > try to assign new materials via the materials array > Press Apply prefab Hope you have a solution! Thanks! * Only "solution" i found was stipping Probuilder scripts on the prefab, then materials were editable again. But...it erases the pb_mesh and it end up with an empty prefab (By the way stripping Probuilder scripts should delete the mesh too? Is it normal stripping behaviour?) Thanks! Sebastien
  3. Hey guys, is it possible to get some help? Ive run into a bug with ProBuilder when i create a cube and assign a material to the cube. i save the cube as a prefab, after saving it as a prefab the material switches back to the default prototype material!!! Any idea how to fix this? Ive tried removing probuilder and reinstalling but it doesnt fix it. I have ProBuilder2-v2.9.5f3-unity56 installed. Thanks
  4. Hey everyone, I have a question on using ProBuilder geometry with prefabs. In our game, we use ProBuilder to create basic dungeon modules as shown in the first attached picture. Of course, such modules are setup as prefabs so that they can be extensively re-used. Now, after placing different prefab instances in a scene, I've noticed that each module/prefab instance is been assigned a unique mesh id (see 2nd picture). I guess ProBuilder generates a unique mesh for each module, even though they are all based on the same prefab (?). So, in a huge scene, I will end up with having a quite huge number of unique meshes. Usually, I would think that it would be better to have just a single mesh and re-use it (e.g. in terms of performance, memory consumption, static batching and such). Therefore, I am wondering if this is something I should be concerned about, or not? Is it worth to think about exporting meshes to .OBJ or .ASSET in terms of optimization? Thanks for your help and all the best, Moritz PS: Sorry, I've just noticed that this is probably the wrong sub-forum to ask this question. Actually, it's not necessarily a feature-request; it would only be one in the case that it turns out that there is optimization potential for improving ProBuilder prefab support. But if this is not the case, you could just move this thread to another sub-forum.
  5. Radivarig

    No prefab preview

    Hello, There is no mesh preview for pb object nor its prefab. In this video from some time ago (Nov 2014) https://youtu.be/7_UTLscyvpE?t=50s I can see it existed (right bottom corner at 50th second). There is also pb mesh (Mesh Filter) attached to the gameobject and when I double click it, it shows the mesh in the icon so I guess it is possible to add it. It would help a lot because I use these objects for prototyping and in other package editor that shows a prefab preview I can't see what's there since it takes the default preview like when fbx object is selected. I'm using ProCore Bundle 1.0.53, ProBuilder2-v2.6.9f3-unity55, Unity 5.5.0f3 Thanks
  6. I've just upgraded to Probuilder Advanced and since then : when I take a prefab (made with probuilder basic before upgrade) and I put it into the scene, all its materials are replaced by Probuilder's default material. :-(
  7. Hi, One of our level designers just submitted a scene to our Git repository, but we found that the scene file was very large (> 100 MB). The scene is actually quite simple, since it consists of the same building copied about 100 times. The building object was created with ProBuilder, then made into a prefab by dragging it to a prefabs folder, then copied a bunch of times. After trying doing this myself, I saw that the mesh generated is actually not reused, hence why there is so much unique mesh data, even if it is supposed to be the exact same. Is this supposed to happen? How should we do it instead? My understanding of (traditional Unity) prefabs is that the mesh data is just stored one time in memory and then reused for each instantiated clone in the scene. How does this work with ProBuilder? I also recorded a GIF to show the situation:
  8. I am using Probuilder Basic for a few prototyping on a procedurally generated map. As such, I need to instantiate the map on Runtime, which consists of creating several Prefab Rooms. Since Unity 5 doesn't support Lightmapped Prefabs, Unity's employees provided a sample project with a solution in this thread: http://forum.unity3d.com/threads/problems-with-instantiating-baked-prefabs.324514/ The solution basically consists of baking every prefab in a separate scene, saving the lightmap data in a special script which, on Awake, adds the lightmap information to the instantiated prefab in whatever scene it is instantiated in. This method worked well in Unity's basic shapes. However, in Probuilder's objects, this happens: The lightmap shows unmapped in each face's corner. After some experimentation, I noticed that, while playing, double flipping the object's normals, or calling "conform normals" fixed the object, becoming this: And after some more experimentation, I concluded that the method which fixes the UVs is "ProBuilder2.EditorCommon.pb_Editor_Mesh_Utility.Optimize()". This Optimize method somehow fixes the UVs, but since it is an editor method, I can't even call it in the object's start to fix the UVs. Also, since I can't see what's inside, I can't know what is fixing the UV's. Can someone help me find a solution to this problem? Thank you very much. Xkynar
  9. - Windows 10 x64 - Unity 5.2.2f1 Personal - ProBuilder 2.4.11f0 If we strip PB scripts in a GameObject and then make it as a Prefab, the Prefab doesn't contains a Mesh Filter anymore :
  10. Protozoaire

    Pb Prefab no visible when duplicated

    - Windows 10 x64 - Unity 5.4.0b9 Personal - ProBuilder Advanced 2.4.11f0 (r4081) Sometimes when I duplicate a Pb Prefab it becomes invisible and the new is visible. So on the screen it seems like we just move the Prefab whereas it's a new one : - If I click on play, the invisible Prefab is visible again. - If I don't click on play on select it, there is an error on the console : NullReferenceException: Object reference not set to an instance of an object ProBuilder2.EditorCommon.pb_Editor.UpdateSelection (Boolean forceUpdate) ProBuilder2.EditorCommon.pb_Editor.OnSelectionChange () System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222) Rethrow as TargetInvocationException: Exception has been thrown by the target of an invocation. System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:232) System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MethodBase.cs:115) UnityEditor.HostView.Invoke (System.String methodName, System.Object obj) (at C:/buildslave/unity/build/Editor/Mono/HostView.cs:187) UnityEditor.HostView.Invoke (System.String methodName) (at C:/buildslave/unity/build/Editor/Mono/HostView.cs:180) UnityEditor.HostView.OnSelectionChange () (at C:/buildslave/unity/build/Editor/Mono/HostView.cs:135)
  11. ProBuilder Basic Windows 10 x64 - Unity 5.3.2f1 Personal - ProBuilder Basic 2.4.10f2 Issue : When a prefab is instantiated (by script in game OR directly from the Project Window to the Scene Window) OR when I drag & drop a GameObject from the Scene Window to the Project Window to create a new prefab:=> the material of this object (on the Scene Window & Game Window) is resetted to "Default_Prototype". But the material of the prefab linked to the Project Window is correct (not "Default_Prototype" but a personnal material). List of steps to replicate the issue: Select a prefab in the Project Window created by ProBuilder Basic and drag & drop it in the Scene Window OR instantiate by script a prefab created by ProBuilder Basic. (This prefab have another materal than "Default_Prototype).=> the material of this object (on the Scene Window & Game Window) is resetted to "Default_Prototype". But the material of the prefab linked to the Project Window is correct (not "Default_Prototype" but a personnal material). Create a new shape with ProBuilder Basic, OR select a GameObject in the scene already created by Probuilder Basic. Remplace the "Default_Prototype" material by another material. Drag & drop this GameObject in the Project Window (to create a new prefab). => the material of this object (on the Scene Window & Game Window) is resetted to "Default_Prototype". But the material of the prefab linked to the Project Window is correct (not "Default_Prototype" but a personnal material).
  12. tango209

    UNet Mesh Disappears

    I have a ProBuilder prefab with a Network Identity attached to it that is dropped into the scene multiple times. When I send a command to the server to destroy any of the scene instances it destroys the selected instance (by netId sent to the server), but all the other instances of that prefab lose their Mesh Filter values (Mesh Filter: [none]; Mesh: Missing (Mesh)). A built in Unity cube with the same non-ProBuilder components works as expected.
  13. When using ProBuilder to create Prefabs, is there a recommended workflow? My current workflow looks like this: Build meshes I need using pb. Drag them onto a GameObject and create a prefab a such. (I need multiple meshes because I need different physics materials on the objects.) Play with Prefabs yay! However, I have seen the Make Assets option and have been wondering if that is the way I should go. Is this the better option? What would a good workflow be? If all of this is in the docs and I missed it, please direct me to it... Thanks!
  14. Hello everyone, When I make a model created by probuilder then save it in the prefabs folder or any folder in the project panel it shows it retains the material that I initially added or sometimes I have to add it myself. Then it stays there for a while, I save project, save scene and carry on probuildering my imagination into models in unity. After sometime, a particular prefab goes for a prefap I think. haha. Meaning the material in the prefab reverts to default_prototype. I thought of changing the default material in Edit/preferences/prototype since I am trying to make a game using only one material which has a texture atlas. But surely that can't be a solution. It restricts my flexibility to use other materials in unity. So does anyone know anykind of way around this problem? I would like to fix it before I proceed with my game modeling in unity. Btw this particular problem doesn't happen when I use primitve shapes provided by uniyt to create a prefab. Regards Imran.
  15. Hi all, How can I instante a prefab with Photon? Photon need to use his method to intestate a prefab, and ProBuilder too.. Any ideas ? Thank you !!! Best regards, AB
×