Jump to content

Search the Community

Showing results for tags 'material'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Introduce Yourself
    • Showcase and WIP
  • ProBuilder
    • General Discussion
    • Bug Reports
    • Feature Requests
    • Extensions
    • Tutorial Requests
    • ProBuilder Contests
    • ProBuilderVR
  • Polybrush
    • Feature Requests
    • General Discussion
  • ProCore Utility Tools
    • ProGrids
    • ProGroups
    • QuickBrush
    • QuickEdit
    • QuickDecals
  • GILES (Generic In-Game Level Editing System)
    • Feature Requests
    • General Discussion

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 16 results

  1. Hey, I know this question has been asked many times but those answer were mainly built around ProBuilder 2 and before Basic and Advanced classification was removed. So coming to the point. How can I replicate face selective behavior like in ProBuilder 2 runtime example and also have capability of applying different material to selected face at runtime (C#). Thanks cheers
  2. Hey guys, is it possible to get some help? Ive run into a bug with ProBuilder when i create a cube and assign a material to the cube. i save the cube as a prefab, after saving it as a prefab the material switches back to the default prototype material!!! Any idea how to fix this? Ive tried removing probuilder and reinstalling but it doesnt fix it. I have ProBuilder2-v2.9.5f3-unity56 installed. Thanks
  3. It would be nice if material palette could automatically include all materials from a folder specified in settings and if Probuilder window could change to palette view when corresponding shortcut is entered. Example usage: [enter shortcut] -> [Probuilder window changes to palette view with material previews] -> [select material] -> [material is applied and palette window changes back]. Even better if palette view would not change back to Probuilder window while a modifier key is pressed down. It would save a lot of time.
  4. I've just upgraded to Probuilder Advanced and since then : when I take a prefab (made with probuilder basic before upgrade) and I put it into the scene, all its materials are replaced by Probuilder's default material. :-(
  5. Hello there, Just wanted to report a couple bugs I ran into with QuickDecals that I haven't seen yet on Mac. The first issue is when packing multiple atlases the data for the first atlas always shows up in the bottom "Atlas Packing Settings" section. I think this might be related to the second bug... The second issue is when placing decals with multiple packed atlases, the wrong material may be assigned to the decal. In my case placing a decal from the 2nd atlas gets assigned the material from the 1st atlas, causing the wrong texture shows up. Here's a visual repro of both issues: http://gfycat.com/PositiveUncommonAlpinegoat Neither are game breaking as (so far) swapping the material out fixes it. But might not be obvious to others. Thanks
  6. Hi, I'm playing around with some runtime editing and I am trying to set a material on a specific face but I can't really figure out how. I basically copied the code from the RuntimeEdit script and added a basic way to try and set the material for the selected face. This is currently my code for doing this. if (Input.GetKeyDown(KeyCode.Alpha1)) { if (currentSelection.IsValid()) { Debug.Log("Set material"); currentSelection.pb.SetFaceMaterial(currentSelection.pb.faces, testMaterial); RefreshSelectedFacePreview(); } } The most confusing part about the "SetFaceMaterial" function, to me at least, is that it was an array of pb_Face. How am I supposed to set the face I want to apply a material to?
  7. ProBuilder Windows 10 x64 - Unity 5.3.4f1 Personal - ProBuilder 2.4.11f0 Issue : When I select a gameObject (created with Probuilder), only the fist time, its material is reseted to "Default_Prototype". List of steps to replicate the issue: Open an Unity scene. Select a gameObject created with Probuilder. => its material is reseted to "Default_Prototype". Then I can change its material, and when I select the gameObject again its material doesn't change BUT if I close my scene or my Unity project, the bug will appear again.
  8. First i download Probuilder lite version to test. With it I design a lot of beutifull things for my game, for example I design a building like the "Mezquita de Cordoba" (the spanish Cordoba Mosque & Cathedral) I was very happy with this design. I think: "if i can design so beautifull things with the free version of probuilder, what can i design with the advanced version?" Then i decide to upgrade. I buy the Probuilder Advanced and later when i go to my game to use the gameobjects i design with Probuilder basic, i discover that all of them was now without any material. I lost all the colors i get in my beautifull temple. Then i think i can modify to add again the materials, but each time i try to drag and drop any material to any gameobject design with Probuilder Basic, i get the same result, the material disapear. I can't get back the beautifull colors to my design.
  9. - Windows 10 x64 - Unity 5.2.2f1 Personal - ProBuilder 2.4.11f0 I noticed that if I apply a material to a PB GameObject's faces (with child), it makes the child's material change too :
  10. Protozoaire

    Material issue with face mode

    - Windows 10 x64 - Unity 5.2.2f1 Personal - ProBuilder 2.4.11f0 1) If the face selection mode is activated (edge and vertex modes not tested), it's not possible to drag and drop a new material to a PB GameObject. 2) If we drag and drop the new material to the Mesh Renderer Component, it works ... but if we load the scene again and select the PB GameObject, the old material is back again :
  11. ProBuilder Basic Windows 10 x64 - Unity 5.3.2f1 Personal - ProBuilder Basic 2.4.10f2 Issue : When a prefab is instantiated (by script in game OR directly from the Project Window to the Scene Window) OR when I drag & drop a GameObject from the Scene Window to the Project Window to create a new prefab:=> the material of this object (on the Scene Window & Game Window) is resetted to "Default_Prototype". But the material of the prefab linked to the Project Window is correct (not "Default_Prototype" but a personnal material). List of steps to replicate the issue: Select a prefab in the Project Window created by ProBuilder Basic and drag & drop it in the Scene Window OR instantiate by script a prefab created by ProBuilder Basic. (This prefab have another materal than "Default_Prototype).=> the material of this object (on the Scene Window & Game Window) is resetted to "Default_Prototype". But the material of the prefab linked to the Project Window is correct (not "Default_Prototype" but a personnal material). Create a new shape with ProBuilder Basic, OR select a GameObject in the scene already created by Probuilder Basic. Remplace the "Default_Prototype" material by another material. Drag & drop this GameObject in the Project Window (to create a new prefab). => the material of this object (on the Scene Window & Game Window) is resetted to "Default_Prototype". But the material of the prefab linked to the Project Window is correct (not "Default_Prototype" but a personnal material).
  12. Hello! So right now I've run into a bit of a hitch in development. We're starting to lose performance on cards Nvidia Geforce 465 and below. One of the things I'm trying to do is to change the shaders used by materials in bulk as a menu option to ease the processing stress. I have it set up to work just fine by grabbing all the Renderer components in the scene and changing their material shaders directly. However, this doesn't work on Probuilder objects, I presume because pb_Object is overriding the old behavior. My question is: Is there any way for me to change the shader of the materials used in a pb_Object at runtime *without* having to strip all pb scripts? I appreciate any help I can get here. EDIT: Just saw the post way below mine about changing out materials. I just want to clarify that I'm not looking to change a material, but rather the shader it uses.
  13. I have a shader effect that relies on different passes happening at different points in the rendering queue, and since every pass in a shader has to happen in the same spot in the queue, that means I have to split my shader into two shaders over two materials. On regular Unity objects and imported meshes, the effect works fine: I put two materials on the submesh, Unity throws a warning about having more materials than submeshes, but otherwise the effect works exactly as intended. With geometry created through ProBuilder, however, only the first material in the element 0 slot gets rendered. In fact, when running the scene, the inspector shows that the materials list reduces down to just the first material on the object, and when the scene is stopped, the materials list reverts back to normal. Is this a bug, or just an intentional limitation on ProBuilder meshes? If it's the latter, is there any sort of workaround? I'm using Unity 5.1.2f1 and ProBuilder v3425 (v3519 won't work for me, but that's another issue), running on Windows 7.
  14. Hello everyone, When I make a model created by probuilder then save it in the prefabs folder or any folder in the project panel it shows it retains the material that I initially added or sometimes I have to add it myself. Then it stays there for a while, I save project, save scene and carry on probuildering my imagination into models in unity. After sometime, a particular prefab goes for a prefap I think. haha. Meaning the material in the prefab reverts to default_prototype. I thought of changing the default material in Edit/preferences/prototype since I am trying to make a game using only one material which has a texture atlas. But surely that can't be a solution. It restricts my flexibility to use other materials in unity. So does anyone know anykind of way around this problem? I would like to fix it before I proceed with my game modeling in unity. Btw this particular problem doesn't happen when I use primitve shapes provided by uniyt to create a prefab. Regards Imran.
  15. The problem: I grab a material from the project heirarchy after having selected the faces I want to apply it to. I drag the material to the faces, and after like 15 seconds it updates, showing me it has applied to the entire model. As a result of the associated lag, and the randomness of whether it applies to the correct faces, and the slowness of the Undo feature, it has taken two hours to add textures to a medium-sized level (something I chose to do after slightly modifying the ProBuilder texture on accident erased all the vertex colors from my level.) The level consists of about 10 of the same prefab hallways, each of which have less than 100 polys. Not a big scene, but lots of lag, too, guys! A 55-second video demonstrating the texture bug:
  16. hi so when i add a new objects with a new material draw calls add by two(+2) shouldn't every material add one draw call? thx
×