Jump to content

Search the Community

Showing results for tags 'Unity'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Introduce Yourself
    • Showcase and WIP
  • ProBuilder
    • General Discussion
    • Bug Reports
    • Feature Requests
    • Extensions
    • Tutorial Requests
    • ProBuilder Contests
    • ProBuilderVR
  • Polybrush
    • Feature Requests
    • General Discussion
  • ProCore Utility Tools
    • ProGrids
    • ProGroups
    • QuickBrush
    • QuickEdit
    • QuickDecals
  • GILES (Generic In-Game Level Editing System)
    • Feature Requests
    • General Discussion

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 12 results

  1. Hey all! First time posting, but a long time user of ProCore. I was recently creating some Unity3d editor tools for an upcoming project of mine when I realized that rolling ProCore into it would be a great help to my efforts. Unfortunately I have the dll version of ProCore and am unable to download the source code version due to not having an invoice for it (It was a free ludlum dare version, so no invoice). I haven't been able to find documentation on the API otherwise, and that's the reason for my post. I was wondering if anyone could give me an example of how to create a new ProBuilder Cube from script? Or if anyone could print out the code for the menu function GameObject->3D Object->ProBuilder Cube. Thanks in advance all!
  2. I was make a level and set colors to my objects. But when i build the game on android the colors will disappear and my object come white ?? What is the problem. Note: the objects is in the EmptyGameObject parrent.
  3. So I'm a little flummoxed at the moment. I have seen tutorials on creating doorways through generating a mesh to extruding a new room. But what happens when there are two existing rooms that need to be connected? Is it just the experimental subtraction? Here are my two rooms: You can see that there is already a doorway, but I'd like to put a window there also. What's the best practice to do this using ProBuilder?
  4. ScrotieFlapWack

    ProBuilder Folder Structure

    Hi, I am new to Unity so I am not very familiar with how the project structure works or how importing plugins from the Asset Store impacts your project's file structure. I like to keep my projects organized and put everything in it's relevant folder. I started a new project with Unity yesterday hoping to start learning and using ProBuilder, within my 'Assets' folder I created a folder called 'Plugins'. From the Asset Store tab I imported Probuilder and ProGrid and dragged the folders for both plugins into my 'Plugins' folder and I got an error and my viewport in Unity crashed. I'm not to sure if by me dragging the folders for the plugins into another folder crashed Unity but I was just wondering when importing the plugins into a project is it always best practice to just simply leave the folders for those plugins as they are? Or do we have the freedom to move them around into other folders we specify? Thanks, Dave.
  5. There is a bug that wont allow you to undo changes made to the mesh with polybrush after entering and exiting playmode. A bug fix would be nice, but it would also be nice to have a reset or undo button in polybrush that resets the mesh back to its original form. Bug produced with: Unity version: 5.4.2p3 Polybrush version: 0.9.9b2 To recreate this issue, create a plane in the scene, edit the shape of the mesh, press the play button, press the play button again to stop playmode, then try pressing Ctrl-z and see that it does not work.
  6. chaddie47

    Reset button

    Put simply, a reset button that allows the mesh to return to its original form.
  7. chaddie47

    Undo bug

    The bug is that you cannot undo after entering then exiting playmode. bug produced on: Unity version: 5.4.2p3 Polybrush version: 0.9.9b2 The bug can be reproduced by making a plane, editing the mesh using polybrush, pressing play, pressing play again to exit playmode, then pressing Ctrl-z to unto the changes to the mesh.
  8. First - LOVE PolyBrush. I use it and ProBuilder extensively in prototyping and level design, so I docked its tool window in a tab in the Unity Editor right next to ProBuilder for easy access - common stuff for most devs, right? If I leave this tab integrated like this, Unity will crash on load the next time I try to open up my project. The only way to get Unity to open my project is to delete the Library folder from it, forcing Unity to re-create all asset handles and project metafiles. It's not unrecoverable, but with all of the asset packs we have, a real time-killer! This has happened 3 times, with the only change made being the integration of PolyBrush as a tab in Unity. Even made a new empty project to try and reproduce the error, and it happens. Unity will load, open to a white screen, then crash within 3 seconds to the report generation dialog. Unity Environment: I'm using the latest PolyBrush Beta & ProBuilder from the Asset Store Unity 5.4.0f3 Open VR - HTC Vive System Config (if it helps): Intel i7-4790K 32GB RAM EVGA GTX970 FTW Windows 10 64 bit
  9. I'm using Probuilder Basic and have been building some geometry without any issues. I then was tweaking the size of stairs I wanted in my level and built a few with differing amounts of steps. When I hit play, I got an error in Unity that read: "Failed setting triangles. Some indices are referencing out of bounds vertices. IndexCount: 510, VertexCount: 6164 UnityEditor.UnityBuildPostprocessor:OnPostprocessScene()" and a severely garbled scene. I'm using Windows 7 x64, Unity 5.1.1f1 Personal, ProBuilder Basic version 2.4.8f1, revision 3764. Not sure exactly what caused it, but it does go away if I disable Static Batching in the PlayerSettings. Deleting the new staircases I made has no effect on the error and it persists. If I re-enable Static Batching the error happens again. I have tried almost all of the options in Repair to no avail. I've attached pictures of the issue below.
  10. DennG

    Normal mapped decals

    Hi Is it possible to do normal mapped decals? Or maybe decals without color at all.. to place bumps on flat surfaces... that'd be awesome! Best regards Dennis
  11. SteinW.

    Hi, everybody! :-)

    Hi! My name is Stein Walsberg, well....it's not my real name. It's the name I use in game development. :-) I am 42 years old, live in Norway where I live with my wife who also help me with graphics and design for my games. I Use Unity together with Playmaker. Released only one game so far. A very small game for Android. I'm currently working on a game, a remake of a game from Commodore 64. Here I will also use the fantastic tool "Pro Builder". I'm also a music composer, even if it's not my main priority. Unity takes to much time, but I try to compose a little bit when I feel for it. :-) I started to compose back in 1989 on Amiga 500 with trackerbased musicprogram called Sound Tracker. I also do a little bit 3D modeling in Blender, but I'm still learning. I know the very basic. :-) Please take a look at our homepage: http://www.walsberg.no You will see some drawings, paintings, etc. from my wife. And also my first game, "Drop n' Shoot" Or my gameblog: http://www.retro-tetro.walsberg.no I haven't updated it for a while, but I will. :-) Have a nice day! Best regards Stein
  12. Hello, I have encountered a bug that will crash Unity3d 4.5.3. 1. Pro builder 2. 3D models created with Pro builder will crash if a 'Substance' is textured to it. (A substance is a material that can be very customized to create a lot of variation). This problem only exists in Unity 4.5.3, this problem does not exist in Unity 4.5.2 or earlier. Substances are: https://www.assetstore.unity3d.com/en/#!/content/2337 & http://www.allegorithmic.com/products/substance-full-database 3. I am currently using Unity3d 4.5.3 Pro. I am running Windows 7. The latest version of ProCore Bundle version 1.0.3 (released July 07, 2014). 4. This problem only exists in the latest version of Unity (4.5.3) because Unity3d added more fixes and additional support for Substances (ctrl+f "substances") http://unity3d.com/unity/whats-new/unity-4.5.3. Substance files are like materials but instead of the .mat extension, it has a .sbsar extension. 5. To recreate the problem: Create a procore object. Attach the texture (.sbsar) to the object. Change any other scene. Exit unity3d. Open up unity3d. Go to the scene with .sbsar and the crash will happen. There are a few free .sbsar files from the Publisher: https://www.assetstore.unity3d.com/en/#!/content/1352 so you can test the problem. 6. the exact error message is "Fatel error! GetManagerFromContext: pointer to object of manager 'RenderSettings' is NULL (table index 18) UnityEditor.DockArea:OnGUI()" Then it has a button to press "Quit" this error happens on just telling Unity3d to change scenes.
×