Jump to content

Minpin Studios

Members
  • Content count

    18
  • Joined

  • Last visited

  1. Minpin Studios

    Can´t make prefabs?

    I used Blender to make some caves and used polybrush to paint textures on them. However when I try making prefabs of the cave modules something goes wrong. If I create a prefab of just the cave model itself it works. But when I apply texture with polybrush the prefab I create turns up "empty", it holds all the stuff in the inspector but when I drag it out into the scene there is nothing there. EDIT: Maybe I shouldn´t use prefabs at all, I tried painting different instances of the modules and I can get much more variations of how they look by not using them as prefabs. Will this "cost" more performance-wise?
  2. Minpin Studios

    Black faces that cant be painted + Nothing works

    karl, I just sent you a PM.
  3. Minpin Studios

    Black faces that cant be painted + Nothing works

    I don´t really remember but I don´t think I closed it before I got this error.
  4. Minpin Studios

    Black faces that cant be painted + Nothing works

    I´m using Windows 10 and Unity 5.4 Imported Polybrush and it worked great until I tried to start painting textures and BAM! A new halt and Polybrush doesn´t work This is what I got for you this time: ArgumentOutOfRangeException: Argument is out of range. Parameter name: index System.Array.InternalArray__get_Item[Vector3] (Int32 index) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System/Array.cs:183) (wrapper managed-to-managed) UnityEngine.Vector3[]:System.Collections.Generic.IList`1.get_Item (int) ProBuilder2.Common.pb_Math.Average (IList`1 v, IList`1 indices) ProBuilder2.Common.pb_Projection.FindBestPlane (IList`1 points, IList`1 indices) pb_Object.RefreshUV (ProBuilder2.Common.pb_Face[] faces) pb_Object.RefreshUV () pb_Object.Refresh () System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222) Rethrow as TargetInvocationException: Exception has been thrown by the target of an invocation. System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:232) System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MethodBase.cs:115) Polybrush.z_ReflectionUtil.Invoke (System.Object target, System.Type type, System.String method, System.Type[] methodParams, BindingFlags flags, System.Object[] args) (at Assets/ProCore/Polybrush/Code/Editor/Classes/z_ReflectionUtil.cs:149) Polybrush.z_ReflectionUtil.Invoke (System.Object target, System.String method, BindingFlags flags, System.Object[] args) (at Assets/ProCore/Polybrush/Code/Editor/Classes/z_ReflectionUtil.cs:106) Polybrush.z_EditableObject.Apply (Boolean rebuildMesh, Boolean optimize) (at Assets/ProCore/Polybrush/Code/Editor/Classes/z_EditableObject.cs:269) Polybrush.z_EditableObject.Revert () (at Assets/ProCore/Polybrush/Code/Editor/Classes/z_EditableObject.cs:313) Polybrush.z_Editor.FinalizeAndResetHovering () (at Assets/ProCore/Polybrush/Code/Editor/Interface/z_Editor.cs:813) Polybrush.z_Editor.OnBrushExit (Polybrush.z_EditableObject editableObject) (at Assets/ProCore/Polybrush/Code/Editor/Interface/z_Editor.cs:785) Polybrush.z_Editor.SetTool (z_BrushTool brushTool) (at Assets/ProCore/Polybrush/Code/Editor/Interface/z_Editor.cs:371) Polybrush.z_Editor.OnDestroy () (at Assets/ProCore/Polybrush/Code/Editor/Interface/z_Editor.cs:237) UnityEditor.DockArea:OnGUI()
  5. Minpin Studios

    Black faces that cant be painted + Nothing works

    That worked, I got it up and running again. But now I´m really worried if I even dare importing Polybrush again
  6. Minpin Studios

    Black faces that cant be painted + Nothing works

    Tried opening up the project and Unity crashes every time now... I did not doing anything else in my project today besides using Polybrush so that is most likely the culprit. The exact same thing happened with a test-project which completely locked up after installing Polybrush. I´m sorry to say it but I have spent a total of around 270$ on your products and I constantly get headaches because of all the bugs.. How do I restore my project, is it even possible?
  7. Minpin Studios

    Black faces that cant be painted + Nothing works

    Any idea of when this will be fixed?
  8. Minpin Studios

    Black faces that cant be painted + Nothing works

    Like this? IndexOutOfRangeException: Array index is out of range. Polybrush.z_SplatSet.LerpWeights (Polybrush.z_SplatSet lhs, Polybrush.z_SplatSet rhs, Int32 mask, System.Single[] alpha) (at Assets/ProCore/Polybrush/Code/Scripts/Type/z_SplatSet.cs:167) Polybrush.z_BrushModeTexture.OnBrushMove (Polybrush.z_BrushTarget target, Polybrush.z_BrushSettings settings) (at Assets/ProCore/Polybrush/Code/Editor/Brush Modes/z_BrushModeTexture.cs:295) Polybrush.z_Editor.OnBrushMove () (at Assets/ProCore/Polybrush/Code/Editor/Interface/z_Editor.cs:774) Polybrush.z_Editor.UpdateBrush (Vector2 mousePosition, Boolean isDrag) (at Assets/ProCore/Polybrush/Code/Editor/Interface/z_Editor.cs:642) Polybrush.z_Editor.OnSceneGUI (UnityEditor.SceneView sceneView) (at Assets/ProCore/Polybrush/Code/Editor/Interface/z_Editor.cs:466) UnityEditor.SceneView.CallOnSceneGUI () (at C:/buildslave/unity/build/Editor/Mono/SceneView/SceneView.cs:2046) UnityEditor.SceneView.HandleSelectionAndOnSceneGUI () (at C:/buildslave/unity/build/Editor/Mono/SceneView/SceneView.cs:1381) UnityEditor.SceneView.OnGUI () (at C:/buildslave/unity/build/Editor/Mono/SceneView/SceneView.cs:1218) System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222)
  9. For whatever reason some of the faces on my probuilder objects get black when I use Polybrush. The black faces can´t be painted on at all. Edit: And just like that nothing works...
  10. Minpin Studios

    Can´t get it to work at all

    I cant get Polybrush to work at all, I have probuilder objects that I want to use Polybrush on but i just get this error: I use Unity 5.4
  11. Minpin Studios

    Set Pivot is blanked out

    Updated to latest 2.5.0 Procore bundle and I can´t set the pivot to center of the geometry anymore.The "Set Pivot" button is greyed out.
  12. Minpin Studios

    Extrude/move problems

    Yes I meant the Shift key. I´m running Unity 5.3.1 and Probuilder 2.4.9f1. It doesn´t matter what I set the snap settings to, things gets messed up regardless. The setting I had when I did the example above was 0.5 meters.
  13. Minpin Studios

    Extrude/move problems

    Hi, you guys have to do something about this, am I the only one having this problem? Extruding is a complete nightmare when using the Ctrl key... The faces get´s messed up like 50% of the times for some reason. I tried changing the preference for the snapping but it doesn´t help. The picture on the left is the thing I want to extrude, and to the right is what happens when i Extrude using the Ctrl key. In this case I wanted to extrude it 0.5m but it get´s messed up regardless of what value it is. The higher the value the more messed up it becomes. Extruding with the Extrude-button works fine. Also moving objects can be a real pain sometimes, let´s say I have 1m snapping and want to move an object 5m to the left. The object then moves forward and backwards on it´s way to the left which means I can´t position it where I want it. A lot of times I have to disable the snapping altogether to get things to work which sucks big time.
  14. There is something wrong with my Probuilder, when I´m working with the UV-editor it get´s incredibly slow sometimes. Autostitching faces sometimes takes like 2 seconds per face. And when i hit Ctrl + Z to undo something it takes forever for it to work and most of the times it just doesn´t work, the Unity editor freezes completely. Probuilder 2.4.8f1 Unity 5.2.3f1
  15. Minpin Studios

    Extrude/move problems

    The thing is that it happens at random. It´s hards to explain what I mean but it´s definetely a bug. If I want to extrude something I don´t want it to get all messed up. I tried chaning the things you said and it helps sometimes but it doesn´t go away completely.
×