Jump to content

Gibmation

Members
  • Content count

    7
  • Joined

  • Last visited

About Gibmation

  • Rank
    Newbie

Profile Information

  • Gender
    Male
  1. Gibmation

    Pause/Lag between editing PBOs

    Hi Karl thanks for the reply. I am not editing any of the existing models, these have many verts but I'm not touching those, I have them turned off. I made the archways using PB's built in geometry arches bridged together. They dont have that many verts. I made a simpler single archway and was also noticing this lag, could this object type be the problem? Have also noticed when making walls from Cube geoo, after wall gets a certain size its starts lagging. Could the actual size of the faces not the amount of verts be the problem? Would PB check the other models or just PBOs? I have noticed the same type of delay if I do a Ctrl A and select all objects in my scene, though not as long. I exported the bridge object to a new project, I can move faces fine here but I do notice a sml lag, but this is liveable, however I selected a face and clicked delete button and unity freezes. When editor response came back I did a Ctr Z and its crashed unity now. You can test this object if you want here... http://linares.gi/video/bridge.rar Try deleting the face with the arches. Thanks G.
  2. Gibmation

    Pause/Lag between editing PBOs

    Hi Guys, Using Unity Pro 5.1.1f1 I have a lot of objects on scene. The objects have not been created with PB. These objects are in ProGroup layers and visibility is turned off on these layers. So only the PBOs are currently visible in editor. I am experiencing some sort of lag while editing PBOs. I am starting off with a simple cube and just creating walls and arches. Eg. If I drag or manually extrude a face, there is a pause between the time I drag and the time it actually moves on screen while this happens the unity is frozen. If I delete or merge faces, maybe only 4 in number, although I can see faces get deleted/merged in seconds on screen, the editor pauses or lags and unity is again frozen - it can take up to 5mins for the editor to become usable again. However I don't get this issue when doing other stuff like connecting or bridging edges. There are no errors in console. You can get a videoclip of this here: http://linares.gi/video/Probuilder.rar As you can imagine a couple minutes lag every time between actions renders ProBuilder practically unusable. Thanks for your help Gus
  3. Gibmation

    Progroups window it freezes Unity

    Sorry wrong paste! Yes this cleared this thanks! G.
  4. Gibmation

    Progroups window it freezes Unity

    I completely removed progroups folder and re-imported with same result. Why is this? Is there any other config file that should be deleted elsewhere, how should I re-install this form scratch? No buttons on panel.
  5. Gibmation

    Progroups window it freezes Unity

    Well? Any ideas? Do you think I will be able to use ProGroups before I complete my project? Thanks
  6. Gibmation

    Progroups window it freezes Unity

    Hi Thanks for the fix, I got and applied the new update via Asset Store. ...But now getting this error... NullReferenceException: Object reference not set to an instance of an object ProGroups.Group.<RemoveNullOrEmpty>m__2 (UnityEngine.GameObject x) (at Assets/ProCore/ProGroups/Scripts/InScene/GroupContainer.cs:35) System.Linq.Enumerable+<CreateWhereIterator>c__Iterator1D`1[unityEngine.GameObject].MoveNext () System.Collections.Generic.List`1[unityEngine.GameObject].AddEnumerable (IEnumerable`1 enumerable) (at /Users/builduser/buildslave/mono-runtime-and-classlibs/build/mcs/class/corlib/System.Collections.Generic/List.cs:128) System.Collections.Generic.List`1[unityEngine.GameObject]..ctor (IEnumerable`1 collection) (at /Users/builduser/buildslave/mono-runtime-and-classlibs/build/mcs/class/corlib/System.Collections.Generic/List.cs:65) System.Linq.Enumerable.ToArray[GameObject] (IEnumerable`1 source) ProGroups.Group.RemoveNullOrEmpty () (at Assets/ProCore/ProGroups/Scripts/InScene/GroupContainer.cs:35) ProGroups.GroupContainer.Clean () (at Assets/ProCore/ProGroups/Scripts/InScene/GroupContainer.cs:308) ProGroups.ProGroups_Window.OnGUI () (at Assets/ProCore/ProGroups/Scripts/Editor/ProGroups_Window.cs:275) System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono-runtime-and-classlibs/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222) Progroups does not appear in Edit>Preferences either. No buttons on panel either. I completely removed progroups folder and re-imported with same result. Why is this? Is there any other config file that should be deleted elsewhere, how should I re-install this form scratch? Thanks G.
  7. Gibmation

    Progroups window it freezes Unity

    I recently purchased your ProCore Utility Bundle. I am having problems with Progroups which has stopped working properly. I deletd all groups and now when I open Progroups window it freezes Unity and I cant close the Progroups panel. I get this error on console... NullReferenceException: Object reference not set to an instance of an object ProGroups.Group.<RemoveNullOrEmpty>m__2 (UnityEngine.GameObject x) (at Assets/ProCore/ProGroups/Scripts/InScene/GroupContainer.cs:32) System.Linq.Enumerable+<CreateWhereIterator>c__Iterator1D`1[unityEngine.GameObject].MoveNext () System.Collections.Generic.List`1[unityEngine.GameObject].AddEnumerable (IEnumerable`1 enumerable) (at /Users/builduser/buildslave/mono-runtime-and-classlibs/build/mcs/class/corlib/System.Collections.Generic/List.cs:128) System.Collections.Generic.List`1[unityEngine.GameObject]..ctor (IEnumerable`1 collection) (at /Users/builduser/buildslave/mono-runtime-and-classlibs/build/mcs/class/corlib/System.Collections.Generic/List.cs:65) System.Linq.Enumerable.ToArray[GameObject] (IEnumerable`1 source) ProGroups.Group.RemoveNullOrEmpty () (at Assets/ProCore/ProGroups/Scripts/InScene/GroupContainer.cs:32) ProGroups.GroupContainer.Clean () (at Assets/ProCore/ProGroups/Scripts/InScene/GroupContainer.cs:305) ProGroups.ProGroups_Window.OnGUI () (at Assets/ProCore/ProGroups/Scripts/Editor/ProGroups_Window.cs:256) System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) (at /Users/builduser/buildslave/mono-runtime-and-classlibs/build/mcs/class/corlib/System.Reflection/MonoMethod.cs:222) All buttons are missing from the Progroups panel. Please can you help with this.
×