Jump to content

Gav

Members
  • Content count

    12
  • Joined

  • Last visited

  1. When I update or have to uninstall + reinstall Probuilder my material palette is reset. Also as my projects get large I might want different palette sets for editing different areas of my maps. Please add a feature to export/save and import/load palettes to the Material Palette window. An extra feature would be a few quick load buttons to load in certain palette sets on one click on the button (and assign a palette file to the button if you right click it). Second request: Please make the Material window dockable, the Shape Tools window too.
  2. By default all objects created using the Probuilder Tools "Shape Tools" window are set to static. Would be great if you could add a checkbox in the "Shape Tools" window to allow models to be created with the static not set. If like me you are creating lots of objects in maps that need to be non-static as all walls move in my game, I don't have to remember to go through un-checking static in my objects all the time. The Shape Tools window already has a "Show Preview" checkbox, so a good place would be just under that one. Second Request: If possible please make the Shape Tool window dockable. Along with the Material window.
  3. Gav

    Unity3D 5 Errors

    When I delete the Probuilder folder (from the Unity Project window) and re-import "Probuilder-v3202-unity" it breaks all my pb objects scripts. I also tried importing to a blank project and with Unity closed move its new Probuilder folder over into my project, that also breaks the scripts. "Probuilder->Repair->Repair Missing Script References" runs and says it fixed 253 objects but doesn't seem to do a thing.
  4. Gav

    Unity3D 5 Errors

    In my main project (not a new project as above), I'm getting the two errors when I try to update ProBuilder: "Assets/ProCore/ProBuilder/API Examples/Misc/HueCube.cs(8,9): error CS0433: The imported type `pb_Object' is defined multiple times" "Assets/ProCore/ProBuilder/API Examples/Runtime Editing/RuntimeEdit.cs(16,24): error CS0433: The imported type `ProBuilder2.Common.pb_Face' is defined multiple times" When I install ProBuilder in my project, I also only have ProGrids in (others removed). I even tried removing the API Examples folder, which led to errors with menus and editor so I deleted those folders. With no errors left I could run. I re-installed just Probuilder but just end up back with the above two errors.
  5. Gav

    Unity3D 5 Errors

    I had an error, needed to tick the "convex" checkboxes in my meshes for Unity 5. Some stupid height error code! Anyway, still not working and I finially tried a new project.... Quickdecals AND Quickedit seem to be causing the error when I install the new ProBuilder. I installed ProCoreComplete in a new U5 project and this is the result: http://gmtdev.com/files/PB/pbu5-3-new-project.jpg Seemed OK with just ProBuilder, went haywire when QuickDecals was installed. I'm just about to go try removeing Quickdecals from my project and then update.... back in a sec.
  6. Gav

    Unity3D 5 Errors

    I'm having the same problem. If I do what you say above, delete the Probuilder folder (in "ProCore/Probuilder") and then import "ProCoreCompleteBundle\ProBuilder2-v3202-unity5", it breaks all the pb_object+pb_entity scripts in the objects. I've tried the Repair tool and even though that says "fixed 271 objects" it doesn't seem to do anything. Upgrading from Probuilder 2947 xxxx to Probuilder 3202 in the Unity 5.0.0f4 Personal edition. Also, if I try to then install the other parts of ProCoreComplete, the Tool-> menu is nearly empty with just a ProBuilder entry and no Probuilder Window. I *think* QuickBrush is killing it as I get errror for QuickBrush in the console window.
  7. Gav

    Problem with Windows Phone

    OK, sorted it out and I have it working now. I thought I had to use Probuilders Instantiate, now learned I can use Unity's Instantiate from a PB Prefab in my assets folder. Originally I thought I had to use "ProBuilder.Instantiate" to create an object (it works and the object is active). Using Unity's instantiate from a prefab creates it inactive for some reason (could be a bug). So, I no longer have using ProBuilder2.Common; and I can build Windows 8 and Phone versions. Thanks anyway!
  8. Gav

    Problem with Windows Phone

    Hi karl, I can't get the first step to work. Building for Windows 8.1 with ProBuilder present I get the serialize errors (as with vicore). If I move the Assets/Procore folder to Assets/Editor/Procore and add the pb_ScenePostProcessor code in a "pb_ScenePostProcessor.cs" file. If I am using ProCore in my code like in my sample copying the on screen pb object with a script like so: using UnityEngine; using System.Collections; using ProBuilder2.Common; public class copy_pb : MonoBehaviour { public GameObject goInScene; GameObject goCopy; // Use this for initialization void Start () { goCopy = (GameObject)ProBuilder.Instantiate(goInScene, goInScene.transform.position, goInScene.transform.rotation); Vector3 trans = goCopy.transform.position; trans.x += 2; goCopy.transform.position = trans; } // Update is called once per frame void Update () { } } I now get ProBuilder2 could not be found errors:
  9. Gav

    Problem with Windows Phone

    Doing the above and moving the Procore folder into an Editor sub-folder breaks code like "using ProBuilder2.Common;" so I can't create Probuilder objects with ProBuilder.Instantiate or do anything else. What am I missing?
  10. I've been having this crash and corruption issue for the past couple of months and finially cut down a project so much it is down to one simple move of a pb object to reproduce. To reproduce:- Unzip the project Add ProCore inside the assets folder (this isn't in the zip). open the scene "assets/scenes/Scene-PillGeneratorLevel.unity". Move the object "pb-Cylinder-60460" into the object SnakeHead\SnakeheadCube so its position is SnakeHead\SnakeheadCube\pb-Cylinder-60460 Hit Play, crash, Unity will no longer load the scene. You can delete the now corrupt "example.unity" file, copy the "example - Copy.unity" and rename your new copy to "example.unity" to start again. This only happens with ProBuilder objects, I'm pretty sure it is to do with Prefabs as the "SnakeHead" object is synced with the Prefab of the same name in the Prefab folder. If you break this connection everything is fine. It's a bit of a pain of a bug as if I forget this happens and I put a PB object as a child of another, that is also Prefab synced, the entire scene is corrupted and I usually lose minimum 30 mins of edits depending on when I made my last backup. GMTDev-PB-Bug-Report.zip
  11. Prototype, Mac, Unity. Being a new user it took a lot of clicking and searching to find documentation. Mostly, the links don't work and/or are missing, I was hoping to watch a nice easy tutorial video too. A couple of notes: 1. Documentation links are wrong/broken. The link should be http://www.protoolsforunity3d.com/docs/probuilder/ Prototype About Dialog: The link "4 Documentation ..... " goes to the website product info page, not any documentation. You don't have a link on the main website to any documentation, despite info headings saying "Complete Tutorials", none that I can find easily at least. The "_PrototypeDocumentation.pdf" that gets installed. The link at the top to the documentation goes to a blank page. See "Helpful Links: Documentation IN-PROGRESS! Check for latest at: www.procore3d.com/docs/probuilder/pb-beta.html". 2. Tutorial videos on Youtube. I have no idea which one is meant to be first. None seem to start with the basics for new to modelling users, a couple do start with a cube but then 60 seconds later you've clicked so many unknown off screen keyboard key combos and created a 50 faced prong object. e.g. How did you pull out the middle of the face here at 1m:48s https://www.youtube.com/watch?v=Tylp-UzEm84&list=UUjZjIjUDd8-zqsDCzyme8eg - I guess these aren't really tutorials for newbies, more tech demos and I should go read the manual. ... off to read the manual.
×