Jump to content

sweetclimusic

Members
  • Content count

    8
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by sweetclimusic

  1. sweetclimusic

    normal thief(stealing?)

    I've read the two threads, but not sure they are the right fit. I am wanting to make soft trees but not with unity tree creator, instead I would like to make trees like this? https://simonschreibt.de/gat/airborn-trees/ basically you have a mass shape thats the tree's body and then the leaves are children that have the same normals as the main tree shape. But the article states this is done in 3ds max or something. So can you do this in Probuilder? I have my tree trunk and I'm now wanting to add the leaves using this style. I've built a untested shader (my first)... as I 've modeled the probuilder mesh that will hold the leaves. Shader "Test Shaders/Normal UV Thief" { Properties { [Normal] _ParentTexBump("Bumpmap",2D) ="bump"{} [Tooltip("Thief Texture is actually the main text to be rerendered")] _ThiefTex("Texture",2D) = "white" {} } SubShader{ Tags{} CGPROGRAM #pragma surface surf StandardSpecular Sampler2D uv_MainTexBump; Sampler2D uv_ThiefTex; struct Input { float2 uv_MainTexBump; float2 uv_ThiefTex; }; #new surface shader for this object void surf (Input IN, inout SurfaceOutput o) { o.Albedo = tex2D (_ThiefTex, IN.uv_ThiefTex).rgba; o.Normal = UnpackNormal (tex2D (_BumpMap, IN.uv_BumpMap)); o.Alpha = 1; } ENDCG } Fallback VertexLit; }
  2. sweetclimusic

    Move vertices position with script

    I'm not sure if it would be the best approach either. The mesh snapshot is a good idea. So was taking this approach first, I've modified this script. But my other idea was to create a 2nd object and weld the verts to that object. Make it transparent or super tiny and use unity animator and move object 2 back and forth. When you build your project dont pb objects get stripped to normal meshes? So is that done last so all scripts know what was previously a pb object?
  3. sweetclimusic

    Move vertices position with script

    I was searching the forums for a way to animate the vertices on a pb object. I wonder if you can help. My object is a bow, If i pull the vertices in the center of the bow string it looks like it is drawn back. Unity animate doesn't detect this movement to use it to animate. So I wanted to animate in script. But my next issue was how do I inform the script which vertices I want to move? using this script if I ignore pb_face and replace with (?) pb_vert How would I select the vertices I want moving? How do I know what to manipulate via script, there is no documentation on pb types. Thanks
  4. sweetclimusic

    cylinder and uv mapping

    I have created a produlider object. I was following the barrel and crate tutorial on youtube. I created a archery target, basically a really short barrel. But looking at it you can see the edges even after a smooth group 1. Any suggestions? Additionally in attempting to map the UV generated to the texture. It doesn't seem to be mapped to the rim of the target. Second screen rim face selected with UV editor. What did I do wrong with the uv mapping? Thanks
  5. sweetclimusic

    cylinder and uv mapping

    Thanks, that did it. I had previously tried to scale the island before posting. Looks like second attempt was needed. Bump the cylinder to 24 sides and it's got rid of the silhouettes.
  6. sweetclimusic

    Black scene probuilder window

    1) Probuilder 2) Scene view crashes when using probuilder 3) macOS 10.12.1, Unity 5.5.0f3 (personal), Probuilder 2.6.9f3 4) Firstly loading my custom layout failed. I had probuilder docked in bottom panel. Had to revert to default layout. I have about 7 probuilder objects. If I hit 'Open Probuilder' it will load as a black panel. 5) It varies in the order to have the black screen appeared. first the probuilder window was set to pop up mode and icon mode. right click the probuilder change to text mode. It updates and displays text, and then I can swap back to icon mode. There were 999+ errors in the console. Closing probuilder window, scene window goes black. I can switch my layouts, but the first loaded scene view window stays black i.e. if I go into 4 split mode. 6) I had moved probuilder asset from the root location... Assets/Addons/ProCore/Probuilder. Which maybe the cause as I've delete probuilder and reimported as I noticed the probuilder settings were no longer in preferences. trying to reproduce now.
  7. sweetclimusic

    Black scene probuilder window

    My subfolder was addons. Moving back and probuilder is still working except the about window you like you pointed out karl. Seems it was a result of a compile error on a cs script in the project. This can be closed.
  8. sweetclimusic

    Black scene probuilder window

    I've done both since posting. Karl that script wasn't in the scene or in use yet. The fact that probuilder was no longer in tools or preference seemingly not 'installed' would be caused by other script erors? I Will try and move it back to it's subfolder. However does it mean anytime one of my scripts doesn't compile this will happen if probuilder is in a sub folder? I've never used an editor extension tool in unity before this. Is that the expected behaviour extension don't run until all compile errors or cleared?
×